ClubLogan.com - Mahindra Renault Logan/Verito Forum
ClubLogan now available on Mobile. Go to ClubLogan.com/forum from your mobile to try.


India's Largest Mahindra Renault Logan/Verito Club
 
ClubLogan.comHomeFAQSearchRegisterLog in
ClubLogan on Facebook
Search
 
 

Display results as :
 
Rechercher Advanced Search
Latest topics
» Petrol smell
Sun Aug 13, 2017 9:05 pm by mmehra

» TIMING BELT REPLACED, PICK UP DEGRADATION
Sun Aug 13, 2017 8:50 pm by mmehra

» Tyre
Fri Jun 02, 2017 2:28 pm by zapping

» Oil smell from A/C vents and Clutch change
Fri Jun 02, 2017 2:26 pm by zapping

» 2010 Logan MCV Horn Wiring diagram
Fri Jun 02, 2017 1:24 pm by zapping

» General information regarding spare parts
Fri Jun 02, 2017 1:18 pm by zapping

» Coolant Temperature Alarm
Tue Mar 14, 2017 1:10 am by vineethev

» Passion and Untiring Efforts
Sun Feb 19, 2017 10:38 pm by martin245

» Which ATF Fluid?
Sun Feb 19, 2017 7:27 pm by mmehra

Who is online?
In total there are 7 users online :: 0 Registered, 0 Hidden and 7 Guests :: 1 Bot

None

Most users ever online was 62 on Tue Mar 13, 2012 6:20 am
Poll
What colour is your Logan?
Toreador Red
20%
 20% [ 130 ]
Mist Silver
19%
 19% [ 123 ]
Fiery Black
18%
 18% [ 120 ]
Sahara Beige
10%
 10% [ 69 ]
Diamond White
20%
 20% [ 132 ]
Green
3%
 3% [ 20 ]
Mystique Purple
4%
 4% [ 25 ]
Java Brown
3%
 3% [ 22 ]
Mocha Green
0%
 0% [ 3 ]
Rocky Beige
3%
 3% [ 19 ]
Total Votes : 663
Social bookmarking
Social bookmarking Digg  Social bookmarking Delicious  Social bookmarking Reddit  Social bookmarking Stumbleupon  Social bookmarking Slashdot  Social bookmarking Yahoo  Social bookmarking Google  Social bookmarking Blinklist  Social bookmarking Blogmarks  Social bookmarking Technorati  

Bookmark and share the address of ClubLogan.com - Mahindra Renault Logan/Verito Forum on your social bookmarking website
Top posters
martin245
 
sAuMiL
 
vsuprak
 
Mir...
 
RajeshNamb
 
ashutosh
 
HITESH
 
nayandeep
 
tomlai
 
Logan_loverinDelhi
 
Clublogan @ Indiblogger
Keywords
light heater battery plug logan line hard steering phone belt vibration timing boot cable change sound vehicle axle clutch wiper water fuel check engine Power idling
August 2017
MonTueWedThuFriSatSun
 123456
78910111213
14151617181920
21222324252627
28293031   
CalendarCalendar

Share | 
 

 Acceleration issue

View previous topic View next topic Go down 
AuthorMessage
nayandeep
Super Loganizer
Super Loganizer
avatar

Male
Number of posts : 447
Age : 37
City, Country : Kolkata, India.
LOGAN Model : DLS 1.5
ClubLogan Points : 264
Registration date : 2008-01-14

PostSubject: Acceleration issue   Sun May 29, 2016 3:23 pm

Since last few days I am facing this issue. My car simply refuses to pick up speed in first and second gear. I have to press the accelerator fully to the ground to get it moving. This worsens when AC is switched on and mostly when engine is cold. Once the AC is turned on there have been repeated jerks in the engine before I can get proper acceleration. After a few minutes of driving this problem goes away and I am not able to recreate this issue in front of the mechanic.

I have changed engine oil, fuel filter, oil filter and air filter 4 months back. Due that service the mechanic told me that all the 4 spark plugs are burnt and I need to change them if there are starting problems. Can the spark plugs cause this intermittent acceleration problem.

Also in the first and second gear I am hearing an odd fan rotation kind of noise once I release the clutch after raising the rpm.
Back to top Go down
View user profile
nayandeep
Super Loganizer
Super Loganizer
avatar

Male
Number of posts : 447
Age : 37
City, Country : Kolkata, India.
LOGAN Model : DLS 1.5
ClubLogan Points : 264
Registration date : 2008-01-14

PostSubject: Re: Acceleration issue   Mon May 30, 2016 3:23 pm

Now the problem is occurring every time when the AC is on. I need to floor the accelerator to get the car moving and as a result lots of black smoke coming out of the exhaust. Anyone experienced this issue ever in Logan?
Back to top Go down
View user profile
martin245
Super Loganizer
Super Loganizer
avatar

Male
Number of posts : 2502
Age : 64
City, Country : Karlsbad Spielberg Germany Some do not like the way I answer posts .but if you read between the lines you will see sense in what I write
LOGAN Model : DACIA LOGAN 14mpi Lauriette Simply Red
ClubLogan Points : 2090
Registration date : 2008-04-07

PostSubject: Re: Acceleration issue   Mon Jul 11, 2016 2:54 pm

I am a bit late with this one ! BUT it sounds like your clutch is (was) slipping
Back to top Go down
View user profile http://www.bo-frost.co.uk
vsuprak
Moderator
Moderator
avatar

Male
Number of posts : 1182
Age : 37
City, Country : Bangalore / IND
LOGAN Model : 1.5DLX Fiery Black - 132,000kms (sold)
ClubLogan Points : 1031
Registration date : 2008-03-17

PostSubject: Re: Acceleration issue   Sun Jul 17, 2016 9:32 am

Hi Nayandeep,

Any update on this issue sine your post in March?
Back to top Go down
View user profile
nayandeep
Super Loganizer
Super Loganizer
avatar

Male
Number of posts : 447
Age : 37
City, Country : Kolkata, India.
LOGAN Model : DLS 1.5
ClubLogan Points : 264
Registration date : 2008-01-14

PostSubject: Re: Acceleration issue   Tue Jul 19, 2016 11:13 am

vsuprak wrote:
Hi Nayandeep,

Any update on this issue sine your post in March?
I had to change all the 4 spark plugs. They were not working. They have like that for a long time and as a result the fuel was not getting burnt properly. Once they are changed and after some good acceleration is done, everything gets back to normal. I had to exhaust out all the black smoke that was throwing out the soot that got accumulated over the years.
Back to top Go down
View user profile
martin245
Super Loganizer
Super Loganizer
avatar

Male
Number of posts : 2502
Age : 64
City, Country : Karlsbad Spielberg Germany Some do not like the way I answer posts .but if you read between the lines you will see sense in what I write
LOGAN Model : DACIA LOGAN 14mpi Lauriette Simply Red
ClubLogan Points : 2090
Registration date : 2008-04-07

PostSubject: Re: Acceleration issue   Mon Aug 29, 2016 2:28 pm

Your car is a Diesel Logan DLS 1.5 and you have no Spark Plugs ! you have Glow Plugs to assist Starting from cold but you do NOT have spark plugs
Back to top Go down
View user profile http://www.bo-frost.co.uk
Thomasmathew
Newbie Loganizer!
Newbie Loganizer!
avatar

Male
Number of posts : 155
Age : 44
City, Country : Delhi, India
LOGAN Model : 1.4 GLE
ClubLogan Points : 224
Registration date : 2008-10-08

PostSubject: Re: Acceleration issue   Sun Jan 01, 2017 11:04 am

Please join the below WhatsApp group for immediate reply regarding your faults so many experts were there to give reply.They are not interested in other groups 
https://chat.whatsapp.com/FNyV1HEGs0xF98o8DoamRd
Back to top Go down
View user profile
martin245
Super Loganizer
Super Loganizer
avatar

Male
Number of posts : 2502
Age : 64
City, Country : Karlsbad Spielberg Germany Some do not like the way I answer posts .but if you read between the lines you will see sense in what I write
LOGAN Model : DACIA LOGAN 14mpi Lauriette Simply Red
ClubLogan Points : 2090
Registration date : 2008-04-07

PostSubject: Re: Acceleration issue   Sun Jan 01, 2017 5:44 pm

The link does not work for me and hey why use whats app this is a forum with people in that own Logans so no need really for another way
Back to top Go down
View user profile http://www.bo-frost.co.uk
Sponsored content




PostSubject: Re: Acceleration issue   

Back to top Go down
 
Acceleration issue
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Tour Issue Equipment
» Help! R9 screw issue
» Danica Patrick SI Swimsuit Issue
» New issue of Vw Camper & Commercial
» Holding back under acceleration

Permissions in this forum:You cannot reply to topics in this forum
ClubLogan.com - Mahindra Renault Logan/Verito Forum :: Mahindra Renault LOGAN - General :: TECHNICAL-
Jump to: